Ongoing issues with syndicated feedback over the weekend

Incident Report for Feefo

Update

We are continuing to actively investigate the issue where feedback submitted since Friday, August 7th is not loading into our reporting or syndication pipelines.

There are no new updates at this time. Please rest assured that all incoming feedback is still being safely captured without data loss. Metrics and syndicated feeds will remain temporarily delayed while our Data Team works toward a resolution.

We will share another update as soon as new information becomes available.
Posted Aug 11, 2026 - 12:34 BST

Investigating

We are actively investigating an issue where feedback submitted since Friday, August 7th is not loading into our reporting or syndication pipelines. All incoming feedback continues to be safely captured, but metrics and syndicated feeds relying on this data will be temporarily delayed while our Data Team works to resolve the issue.
Posted Aug 10, 2026 - 12:19 BST
This incident affects: Feefo Hub (Feedback).