Degraded Performance of the Feefo Platform.

Incident Report for Feefo

Resolved

This incident has now been resolved. This incident was a result of a Google service incident across their London data centres. Preliminary root cause was identified as an issue within Googles network infrastructure. Thank you for your patience.
Posted Jun 10, 2026 - 16:20 BST

Update

We are monitoring an ongoing issue affecting multiple Google Cloud services. At this time, we are observing little to no impact on our platform. We will continue to monitor the situation closely and provide updates if conditions change.
Posted Jun 10, 2026 - 15:36 BST

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 11:48 BST

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 11:30 BST

Investigating

We are currently aware of an issue effecting the Feefo platform as a whole, resulting in unstable connections to the Feefo Hub and issues with our APIs. Our engineering team is actively investigating the root cause as a matter of priority. We apologise for the disruption and will provide further updates here as soon as we have more information.
Posted Jun 10, 2026 - 11:22 BST
This incident affected: Feefo Hub (Login), Review Display (Integration Widgets), APIs (Authentication, Reviews, Product Ratings), and Third-party Services (Database -1, Database -2, Database -3, Kubernetes Cluster, Cloud Compute).