Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2026 - 00:15 BST
Scheduled
Our customer support software provider is currently undergoing scheduled system maintenance. Because our help desk relies on their platform, our usual support channels are temporarily impacted.
How this affects our services:
Live Chat Unavailable: Because the underlying platform is offline, our live chat widget is temporarily turned off and cannot be accessed.
Delayed Ticket Creation: You can still send messages to our support email, but new tickets will not be generated or routed to our team until the vendor completes their maintenance. Your emails are being safely held in a queue.
Our provider estimates the maintenance will be completed by the end of the day on 19th July. Once their systems are back online, ticket creation and live chat will automatically resume, and our team will work through the queued messages as quickly as possible.
Posted Jul 17, 2026 - 09:59 BST
This scheduled maintenance affected: Feefo Support Platform - Ticketing System.