API Latency Issues

Incident Report for Feefo

Resolved

This issue has now been resolved, thanks for your patience.
Posted May 22, 2026 - 14:10 BST

Investigating

We are currently investigating an issue causing increased latency on our platform. Our engineering team is actively diagnosing the root cause and working to restore normal performance levels as quickly as possible.

We sincerely apologise for the disruption and will provide another update as soon as more information becomes available.
Posted May 22, 2026 - 13:46 BST
This incident affected: APIs (Reviews, Product Ratings).