Investigating API Issues

Incident Report for Feefo

Resolved

We have completed testing and confirmed that the issue has been fully resolved. Thank you for your continued patience.
Posted Aug 07, 2026 - 17:54 BST

Update

Testing on the Download Feedback API remains underway. We are currently running an automated script to address the underlying issue and are actively monitoring its progress. Because the duration of this process depends on database processing times, we are unable to provide an exact estimated time of completion at present.

We will provide another status update as soon as the script completes or if any further developments occur. Thank you for your continued patience.
Posted Aug 07, 2026 - 11:17 BST

Update

We are continuing to perform maintenance on the Download Feedback API but were unable to come to a final resolution today, we are currently testing a possible solution and hope to have a full resolution tomorrow (07/08/2026).
Posted Aug 06, 2026 - 17:31 BST

Identified

We believe we have identified the root cause of the issue effecting our Download Feedback API and the Download Feedback function in the Feefo Hub. A fix is being tested and upon confirmation of successful resolution, this fix will be applied to our production environment. We hope to have this issue resolved in full by the end of the day (06/08/2026). Thank you for your continued patience.
Posted Aug 06, 2026 - 10:07 BST

Update

Testing is still underway for the identified fix regarding the 500 errors with our Download Feedback API and Feefo Hub feedback downloads. We currently expect the fix to be potentially ready for release tomorrow. We will provide another update as testing concludes or new details become available.
Posted Aug 05, 2026 - 17:19 BST

Update

We are currently investigating intermittent 500 errors impacting the Download Feedback API and downloading feedback through the Feefo Hub. Our engineering team has identified a potential fix and is currently testing the resolution. We will share another update as soon as testing is complete.
Posted Aug 05, 2026 - 15:06 BST

Investigating

We are currently experiencing performance issues with our Download Feedback API, resulting in 500 errors. Applications and integrations may encounter errors when requesting or providing information related to downloading feedback. Our engineering team is investigating the cause as a priority and will update this page shortly.

Please be aware this issue only effects our Download Feedback API, all other APIs are currently working as expected.
Posted Aug 05, 2026 - 11:29 BST
This incident affected: APIs (Reviews).