Feedback request processing

Incident Report for Feefo

Resolved

The feedback request backlog will now have cleared and service has returned to normal. Thank you for your patience.
Posted Jul 21, 2026 - 10:51 BST

Monitoring

Our engineering teams have made progress to identify the cause of this outage and have begun monitoring feedback requests that have begun to send as expected. We will continue to monitor this until service has returned to normal. Thank you for your patience.
Posted Jul 20, 2026 - 17:19 BST

Investigating

We are currently investigating an issue impacting the processing of feedback requests, causing a backlog waiting to send for some of our customers. ur engineering team is actively investigating the root cause as a matter of priority. We apologise for the disruption and will provide further updates here as soon as we have more information.
Posted Jul 20, 2026 - 11:02 BST
This incident affected: Feedback Process (Feedback Requests (Email, SMS)).