Feefo Widgets & API Latency Issues

Incident Report for Feefo

Resolved

This issue has now been resolved, thanks for your patience.
Posted May 04, 2026 - 10:30 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2026 - 09:54 BST

Investigating

We are actively resolving an issue with high latency and error rates on on-page APIs impacting approximately 15% of traffic.

Please accept our apologies for the inconvenience.
Posted May 04, 2026 - 08:30 BST
This incident affected: Review Display (Integration Widgets) and APIs (Reviews, Product Ratings).